svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wcsftime(3c)
Standard C Library Functions wcsftime(3C)
NAME
wcsftime - convert date and time to wide character string
SYNOPSIS
#include <wchar.h>
XPG4 and SUS
size_t wcsftime(wchar_t *wcs, size_t maxsize, const char *format,
const struct tm *timptr);
Default and other standards
size_t wcsftime(wchar_t *restrict wcs, size_t maxsize,
const wchar_t *restrict format,
const struct tm *restrict timptr);
DESCRIPTION
The wcsftime() function is equivalent to the strftime(3C) function,
except that:
o The argument wcs points to the initial element of an array
of wide-characters into which the generated output is to be
placed.
o The argument maxsize indicates the maximum number of wide-
characters to be placed in the output array.
o The argument format is a wide-character string and the con‐
version specifications are replaced by corresponding
sequences of wide-characters.
o The return value indicates the number of wide-characters
placed in the output array.
If copying takes place between objects that overlap, the behavior is
undefined.
RETURN VALUES
If the total number of resulting wide character codes (including the
terminating null wide-character code) is no more than maxsize, wcsf‐
time() returns the number of wide-character codes placed into the array
pointed to by wcs, not including the terminating null wide-character
code. Otherwise, 0 is returned and the contents of the array are inde‐
terminate.
The wcfstime() function uses malloc(3C) and should malloc() fail, errno
will be set by malloc().
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityCommitted _ MT-LevelMT-
Safe _ StandardSee standards(7).
SEE ALSO
malloc(3C), setlocale(3C), strftime(3C), attributes(7), standards(7)
Oracle Solaris 11.4 7 Oct 2014 wcsftime(3C)