svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
wcscoll(3c)
Standard C Library Functions wcscoll(3C)
NAME
wcscoll, wcscoll_l, wscoll - wide character string comparison using
collating information
SYNOPSIS
#include <wchar.h>
int wcscoll(const wchar_t *ws1, const wchar_t *ws2);
int wcscoll_l(const wchar_t *ws1, const wchar_t *ws2 locale_t locale);
int wscoll(const wchar_t *ws1, const wchar_t *ws2);
DESCRIPTION
The wcscoll() and wscoll() functions compare the wide character string
pointed to by ws1 to the wide character string pointed to by ws2, both
interpreted as appropriate to the LC_COLLATE category of the current
locale.
The wcscoll_l() function is equivalent to the wcscoll() function,
except that the locale data used is from the locale represented by
locale.
The behavior is undefined if the locale argument to wcscoll_l() is the
special locale object LC_GLOBAL_LOCALE or is not a valid locale object
handle.
The wcscoll(), wcscoll_l(), and wscoll() functions do not change the
setting of errno if successful.
An application wanting to check for error situations should set errno
to 0 before calling wcscoll(), wcscoll_l() or wscoll(). If errno is
non-zero on return, an error has occurred.
RETURN VALUES
Upon successful completion, wcscoll() and wscoll() return an integer
greater than, equal to, or less than 0, depending upon whether the wide
character string pointed to by ws1 is greater than, equal to, or less
than the wide character string pointed to by ws2, when both are inter‐
preted as appropriate to the current locale.
wcscoll_l() is equivalent to wcscoll(), execpt that locale data used is
from the locale represented by locale. On error, wcscoll() and wscoll()
may set errno, but no return value is reserved to indicate an error.
ERRORS
These functions may fail if:
EINVAL The ws1 or ws2 arguments contain wide character codes outside
the domain of the collating sequence.
USAGE
The wcsxfrm(3C) and wcscmp(3C) functions should be used for sorting
large lists.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface Stabilitywcscoll() and
wcscoll_l() are Standard _ MT-LevelMT-Safe
SEE ALSO
duplocale(3C), freelocale(3C), newlocale(3C), setlocale(3C), uselo‐
cale(3C), wcscmp(3C), wcsxfrm(3C), attributes(7), standards(7)
Oracle Solaris 11.4 27 Nov 2017 wcscoll(3C)