svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
vwprintf_s(3c)
Standard C Library Functions vfwprintf(3C)
NAME
vfwprintf, vwprintf, vswprintf, vfwprintf_s, vwprintf_s, vswprintf_s,
vsnwprintf_s - wide-character formatted output of a stdarg argument
list
SYNOPSIS
#include <stdarg.h>
#include <stdio.h>
#include <wchar.h>
int vwprintf(const wchar_t *restrict format, va_list arg);
int vfwprintf(FILE *restrict stream, const wchar_t *restrict format,
va_list arg);
int vswprintf(wchar_t *restrict s, size_t n,
const wchar_t *restrict format, va_list arg);
#define __STDC_WANT_LIB_EXT1__ 1
#include <stdio.h>
#include <wchar.h>
int vwprintf_s(const wchar_t *restrict format, va_list arg);
int vfwprintf_s(FILE *restrict stream, const wchar_t *restrict format,
va_list arg);
int vswprintf_s(wchar_t *restrict s, rsize_t n,
const wchar_t *restrict format, va_list arg);
int vsnwprintf_s(wchar_t *restrict s, rsize_t n,
const wchar_t *restrict format, va_list arg);
DESCRIPTION
The vwprintf(), vfwprintf(), vswprintf(), vwprintf_s(), vfwprintf_s(),
vswprintf_s(), and vsnwprintf_s() functions are the same as wprintf(),
fwprintf(), swprintf(), wprintf_s(), fwprintf_s(), swprintf_s(), and
snwprintf_s() respectively, except that instead of being called with a
variable number of arguments, they are called with an argument list as
defined by <stdarg.h>.
These functions do not invoke the va_end() macro. However, as these
functions do invoke the va_arg() macro, the value of ap after the
return is indeterminate.
RETURN VALUES
Refer to fwprintf(3C).
ERRORS
Refer to fwprintf(3C).
USAGE
Applications using these functions should call va_end(ap) afterward to
clean up.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSee
fwprintf(3C). _ StandardSee fwprintf(3C).
SEE ALSO
fwprintf(3C), setlocale(3C), attributes(7), standards(7), runtime_con‐
straint_handler(3C)
HISTORY
See fwprintf(3C).
Oracle Solaris 11.4 30 Jul 2021 vfwprintf(3C)