svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
volmgt_symname(3volmgt)
Volume Management Library Functions volmgt_symname(3VOLMGT)
NAME
volmgt_symname, volmgt_symdev - convert between Volume Management sym‐
bolic names, and the devices that correspond to them
SYNOPSIS
cc [ flag... ] file... -lvolmgt [ library... ]
#include <volmgt.h>
char *volmgt_symname(char *pathname);
char *volmgt_symdev(char *symname);
DESCRIPTION
This function is obsolete. The management of removable media by the
Volume Management feature, including vold, has been replaced by soft‐
ware that supports the Hardware Abstraction Layer (HAL). Programmatic
support for HAL is through the HAL APIs, which are documented on the
HAL website. See hal(7). The return value of this function is unde‐
fined.
These two routines compliment each other, translating between Volume
Management's symbolic name for a device, called a symname, and the /dev
pathname for that same device.
volmgt_symname() converts a supplied /dev pathname to a symname, Vol‐
ume Management's idea of that device's symbolic name.
volmgt_symdev() does the opposite conversion, converting between a sym‐
name, Volume Management's idea of a device's symbolic name for a vol‐
ume, to the /dev pathname for that device.
RETURN VALUES
The return from this function is undefined.
ERRORS
volmgt_symname() can fail, returning a null string pointer, if a
stat(2) of the supplied pathname fails, or if an open(2) of /dev/volctl
fails, or if any of the following is true:
ENXIO Volume Management is not running.
EINTR An interrupt signal was detected while trying to convert the
supplied pathname to a symname.
volmgt_symdev() can fail if an open(2) of /dev/volctl fails, or if any
of the following is true:
ENXIO Volume Management is not running.
EINTR An interrupt signal was detected while trying to convert the
supplied symname to a /dev pathname.
EXAMPLES
Example 1 Finding The symbolic name
This code finds out what symbolic name (if any) Volume Management has
for /dev/rdsk/c0t6d0s2:
if ((nm = volmgt_symname("/dev/rdsk/c0t6d0s2")) == NULL) {
(void) printf("path not managed\n");
} else {
(void) printf("path managed as %s\n", nm);
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe _ Interface StabilityObsolete
SEE ALSO
open(2), stat(2), free(3C), malloc(3C), volmgt_check(3VOLMGT),
volmgt_inuse(3VOLMGT), volmgt_running(3VOLMGT), attributes(7), hal(7)
Oracle Solaris 11.4 11 May 2021 volmgt_symname(3VOLMGT)