svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
volmgt_running(3volmgt)
Volume Management Library Functions volmgt_running(3VOLMGT)
NAME
volmgt_running - return whether or not volume management is running
SYNOPSIS
cc [ flag... ] file... -lvolmgt [ library... ]
#include <volmgt.h>
int volmgt_running(void);
DESCRIPTION
This function is obsolete. The management of removable media by the
Volume Management feature, including vold, has been replaced by soft‐
ware that supports the Hardware Abstraction Layer (HAL). Programmatic
support for HAL is through the HAL APIs, which are documented on the
HAL website. See hal(7).
volmgt_running() tells whether or not Volume Management is running.
RETURN VALUES
volmgt_running() always returns 0 indicating Volume Management (as
implemented by vold) is not running.
ERRORS
volmgt_running() will fail, returning 0, if a stat(2) or open(2) of
/dev/volctl fails, or if any of the following is true:
ENXIO Volume Management is not running.
EINTR An interrupt signal was detected while checking to see if Vol‐
ume Management was running.
EXAMPLES
Example 1 Using volmgt_running()
To see if Volume Management is running:
if (volmgt_running() != 0) {
(void) printf("Volume Management is running\n");
} else {
(void) printf("Volume Management is NOT running\n");
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe _ Interface StabilityObsolete
SEE ALSO
open(2), stat(2), volmgt_check(3VOLMGT), volmgt_inuse(3VOLMGT),
attributes(7), hal(7)
NOTES
Volume Management must be running for many of the Volume Management
library routines to work.
Oracle Solaris 11.4 11 May 2021 volmgt_running(3VOLMGT)