svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
volmgt_root(3volmgt)
Volume Management Library Functions volmgt_root(3VOLMGT)
NAME
volmgt_root - return the volume management root directory
SYNOPSIS
cc [ flag... ] file... -lvolmgt [ library ... ]
#include <volmgt.h>
const char *volmgt_root(void);
DESCRIPTION
This function is obsolete. The management of removable media by the
Volume Management feature, including vold, has been replaced by soft‐
ware that supports the Hardware Abstraction Layer (HAL). Programmatic
support for HAL is through the HAL APIs, which are documented on the
HAL website. See hal(7). The return value of this function is unde‐
fined.
The volmgt_root() function returns the current volume management root
directory, which by default is /vol but can be configured to be in a
different location.
RETURN VALUES
The return from this function is undefined.
ERRORS
This function may fail if an open() of /dev/volctl fails. If this
occurs a pointer to the default Volume Management root directory is
returned.
EXAMPLES
Example 1 Finding the Volume Management Root directory.
To find out where the volume management root directory is:
if ((path = volmgt_root()) != NULL) {
(void) printf("Volume Management root dir=%s\n", path);
} else {
(void) printf("can't find Volume Management root dir\n");
}
FILES
/dev default location for the volume management root directory
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe _ Interface StabilityObsolete
SEE ALSO
open(2), volmgt_check(3VOLMGT), volmgt_inuse(3VOLMGT), volmgt_run‐
ning(3VOLMGT), attributes(7), hal(7)
NOTES
This function returns the default root directory location even when
volume management is not running.
Oracle Solaris 11.4 11 May 2021 volmgt_root(3VOLMGT)