svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
volmgt_check(3volmgt)
Volume Management Library Functions volmgt_check(3VOLMGT)
NAME
volmgt_check - have Volume Management check for media
SYNOPSIS
cc [ flag... ] file... -lvolmgt [ library ... ]
#include <volmgt.h>
int volmgt_check(char *pathname);
DESCRIPTION
This function is obsolete. The management of removable media by the
Volume Management feature, including vold, has been replaced by soft‐
ware that supports the Hardware Abstraction Layer (HAL). Programmatic
support for HAL is through the HAL APIs, which are documented on the
HAL website. See hal(7). The return value of this function is unde‐
fined.
This routine asks volume Management to check the specified pathname and
determine if new media has been inserted in that drive.
If a null pointer is passed in, then Volume Management will check each
device it is managing that can be checked.
If new media is found, volmgt_check() tells volume management to initi‐
ate appropriate actions.
RETURN VALUES
The return from this function is undefined.
ERRORS
This routine can fail, returning 0, if a stat(2) or open(2) of the sup‐
plied pathname fails, or if any of the following is true:
ENXIO volume management is not running.
EINTR An interrupt signal was detected while checking for media.
EXAMPLES
Example 1 Checking If Any New Media Is Inserted
To check if any drive managed by volume management has any new media
inserted in it:
if (volmgt_check(NULL)) {
(void) printf("Volume management found media\n");
}
This would also request volume management to take whatever action was
appropriate for the new media.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
volcheck(1), open(2), stat(2), volmgt_inuse(3VOLMGT), volmgt_run‐
ning(3VOLMGT), attributes(7), hal(7)
NOTES
Since volmgt_check() returns 0 for two different cases (both when no
media is found, and when an error occurs), it is up to the user to
check errno to differentiate the two, and to ensure that volume manage‐
ment is running.
Oracle Solaris 11.4 11 May 2021 volmgt_check(3VOLMGT)