vm_page_wire(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

vm_page_wire(9)

VM_PAGE_WIRE(9)          BSD Kernel Developer's Manual         VM_PAGE_WIRE(9)

NAME
     vm_page_wire, vm_page_unwire — wire and unwire pages

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_wire(vm_page_t m);

     void
     vm_page_unwire(vm_page_t m, int activate);

DESCRIPTION
     The vm_page_wire() function increments the wire count on a page, and
     removes it from whatever queue it is on.

     The vm_page_unwire() function releases one of the wirings on the page.
     When write_count reaches zero the page is placed back onto either the
     active queue (if activate is non-zero) or onto the inactive queue (if
     activate is zero).  If the page is unmanaged (PG_UNMANAGED is set) then
     the page is left on PQ_NONE.

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

BSD                              July 13, 2001                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3