vm_page_rename(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

vm_page_rename(9)

VM_PAGE_RENAME(9)        BSD Kernel Developer's Manual       VM_PAGE_RENAME(9)

NAME
     vm_page_rename — move a page

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_rename(vm_page_t m, vm_object_t new_object,
         vm_pindex_t new_pindex);

DESCRIPTION
     The vm_page_rename() function removes a page from one object, and adds it
     to another at the given page index.  The page is added to the given
     object, and is removed from the object that is currently associated with.
     If the page is currently on the cache queue it will be deactivated unless
     it is wired or unmanaged, in which case the deactivation will fail.  The
     entire page is marked as dirty after the move.

     The arguments to vm_page_rename() are:

     m           The page to move.

     new_object  The object the page should be inserted into.

     new_pindex  The page index into new_object at which the new page should
                 be inserted.

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

BSD                              July 17, 2001                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3