vm_page_hold(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

vm_page_hold(9)

VM_PAGE_HOLD(9)          BSD Kernel Developer's Manual         VM_PAGE_HOLD(9)

NAME
     vm_page_hold, vm_page_unhold — update a page's hold count

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_hold(vm_page_t m);

     void
     vm_page_unhold(vm_page_t m);

DESCRIPTION
     The vm_page_hold() function increases the hold count on a page.  This
     prevents the page daemon from freeing the page.

     vm_page_hold() should only be used for very temporary wiring of a page,
     as that page will not be considered for paging or reallocation for as
     long as its hold count is greater than zero.  Also note that while wired
     pages are removed from whatever queue they are on, vm_page_hold() does
     not affect the location of the page.  If it is on a queue prior to the
     call, it will still be there afterward.

     If the page needs to be held for a long period of time, vm_page_wire(9)
     should be used.

     vm_page_unhold() function reduces the hold count on a page.  If the hold
     count is zero it is possible that the page will be freed by the page dae‐
     mon.

SEE ALSO
     vm_page_unwire(9), vm_page_wire(9)

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

BSD                              July 13, 2001                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3