vget(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

vget(9)

VGET(9)                  BSD Kernel Developer's Manual                 VGET(9)

NAME
     vget — get a vnode from the free list

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     vget(struct vnode *vp, int lockflag, struct thread *td);

DESCRIPTION
     Get a vnode from the free list and increment its reference count.

     vp        The vnode to remove from the free list.

     lockflag  If non-zero, the vnode will also be locked.

     When not in use, vnodes are kept on a free list.  The vnodes still refer‐
     ence valid files but may be reused to refer to a new file at any time.
     Often, these vnodes are also held in caches in the system, such as the
     name cache.

     When a vnode which is on the free list is used again, for instance if the
     vnode was found in the name cache as a result of a call to VOP_LOOKUP(9)
     then the new user must call vget() to increment the reference count and
     remove it from the free list.

SEE ALSO
     vnode(9), vput(9), vref(9), vrele(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD                              July 24, 1996                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3