vflush(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

vflush(9)

VFLUSH(9)                BSD Kernel Developer's Manual               VFLUSH(9)

NAME
     vflush — flush vnodes for a mount point

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     vflush(struct mount *mp, int rootrefs, int flags, struct thread *td);

DESCRIPTION
     The vflush() function removes any vnodes in the vnode table that belong
     to the given mount structure.

     Its arguments are:

     mp        The mount point whose vnodes should be removed.

     rootrefs  The number of references expected on the root vnode.  vrele(9)
               will be invoked on the root vnode rootrefs times.

     flags     The flags indicating how vnodes should be handled.

               FORCECLOSE  If set, busy vnodes will be forcibly closed.

               SKIPSYSTEM  If set, vnodes with the VV_SYSTEM flag set will be
                           skipped.

               WRITECLOSE  If set, only regular files currently opened for
                           writing will be removed.

     td        The calling thread.

RETURN VALUES
     A value of 0 is returned if the flush is successful; otherwise, EBUSY
     will be returned.

SEE ALSO
     vgone(9), vrele(9)

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

BSD                            November 21, 2001                           BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3