svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
usleep(3c)
Standard C Library Functions usleep(3C)
NAME
usleep - suspend execution for interval in microseconds
SYNOPSIS
#include <unistd.h>
int usleep(useconds_t useconds);
DESCRIPTION
The usleep() function suspends the caller from execution for the number
of microseconds specified by the useconds argument. The actual suspen‐
sion time might be less than requested because any caught signal will
terminate usleep() following execution of that signal's catching rou‐
tine. The suspension time might be longer than requested by an arbi‐
trary amount because of the scheduling of other activity in the system.
If the value of useconds is 0, then the call has no effect.
The use of the usleep() function has no effect on the action or block‐
age of any signal. In a multithreaded process, only the invoking thread
is suspended from execution.
RETURN VALUES
On completion, usleep() returns 0. There are no error returns.
ERRORS
No errors are returned.
USAGE
The usleep() function is included for its historical usage. The
nanosleep(3C) function is preferred over this function.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
nanosleep(3C), sleep(3C), attributes(7), standards(7)
Oracle Solaris 11.4 5 Feb 2008 usleep(3C)