svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
uselocale(3c)
Standard C Library Functions uselocale(3C)
NAME
uselocale - use locale in current thread
SYNOPSIS
#include <locale.h>
locale_t uselocale(locale_t newloc);
DESCRIPTION
The uselocale() function sets or query the current locale for the call‐
ing thread.
The value for the newloc argument shall be one of the following:
1. A value returned by the newlocale() or duplocale() functions
2. The special locale object descriptor LC_GLOBAL_LOCALE
3. (locale_t)0
If the newloc argument is (locale_t)0, the current locale is not
changed. This value can be used to query the current locale setting. If
the newloc argument is LC_GLOBAL_LOCALE, any thread-local locale for
the calling thread is uninstalled. The thread again use the global
locale as the current locale, and changes to the global locale affects
the thread. Otherwise, the locale represented by newloc is installed as
a thread-local locale to be used as the current locale for the calling
thread.
Once the uselocale() function has been called to install a thread-local
locale, the behavior of every interface using data from the current
locale is affected for the calling thread. The current locale for other
threads remains unchanged.
RETURN VALUES
Upon successful completion, the uselocale() function returns a handle
for the thread-local locale that was in use as the current locale for
the calling thread on entry to the function, or LC_GLOBAL_LOCALE if no
thread-local locale was in use. Otherwise, uselocale() return
(locale_t)0 and set errno to indicate the error.
ERRORS
The uselocale() function will fail if:
[EINVAL] newloc is not a valid locale object and is not (locale_t)0.
USAGE
Unlike the setlocale() function, the uselocale() function does not
allow replacing some locale categories only. Applications that need to
install a locale which differs only in a few categories must use newlo‐
cale() to change a locale object equivalent to the currently used
locale and install it.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7)
SEE ALSO
duplocale(3C), freelocale(3C), newlocale(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 27 Nov 2017 uselocale(3C)