usb_get_current_frame_number(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

usb_get_current_frame_number(9f)

Kernel Functions                              usb_get_current_frame_number(9F)



NAME
       usb_get_current_frame_number - Return current logical usb frame number

SYNOPSIS
       #include <sys/usb/usba.h>

       usb_frame_number_t usb_get_current_frame_number(dev_info_t *dip);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip    Pointer to the device's dev_info structure.


DESCRIPTION
       The usb_get_current_frame_number() function retrieves the current logi‐
       cal USB frame number.


       Isochronous requests can be started on a particular numbered frame.  An
       offset  number  of  frames (typically between 4 and 10) can be added to
       the current logical frame number to specify the number of  an  upcoming
       frame to start an isochronous request.


       The  USB  specification  requires  that the frame frequency (the period
       between start-of-frame packets) is one millisecond. The Solaris operat‐
       ing  system  USB implementation uses a running counter of the number of
       milliseconds since boot as the current logical frame number.

RETURN VALUES
       On success, the  usb_get_current_frame_number()  function  returns  the
       current  USB  frame number. On failure it returns 0. The function fails
       if dip is NULL.

CONTEXT
       May be called from user, kernel or interrupt context.

EXAMPLES
             usb_pipe_handle_t handle;
             usb_frame_number_t offset = 10;
             usb_isoc_req_t *isoc_req;

             isoc_req = usb_alloc_isoc_req(...);
               ...
               ...
             isoc_req->isoc_frame_no = usb_get_current_frame_number(dip) + offset;
             isoc_req->isoc_attributes = USB_ATTRS_ISOC_START_FRAME;
               ...
               ...
             if (usb_pipe_isoc_xfer(handle, isoc_req, 0) != USB_SUCCESS) {
               ...
             }


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE  VALUE  _  ArchitecturePCI-based systems _ Interface Stability‐
       Committed _ Availabilitysystem/io/usb


SEE ALSO
       attributes(7),                                  usb_alloc_isoc_req(9F),
       usb_get_max_pkts_per_isoc_request(9F),     usb_pipe_get_max_bulk_trans‐
       fer_size(9F), usb_pipe_isoc_xfer(9F), usb_isoc_request(9S)



Oracle Solaris 11.4               11 Dec 2020
                                              usb_get_current_frame_number(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3