svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
typeset(1)
typeset(1) User Commands typeset(1)
NAME
typeset, whence - shell built-in functions to set/get attributes and
values for shell variables and functions
SYNOPSIS
typeset [-CDHLRZfilrtux [n]] [name[=value]]...
whence [-pv] name...
DESCRIPTION
typeset sets attributes and values for shell variables and functions.
When typeset is invoked inside a function, a new instance of the vari‐
ables name is created. The variables value and type are restored when
the function completes. The following list of attributes is supported:
-C Compound variable. Each name is a compound variable. If value
names a compound variable it is copied to name. Otherwise if the
variable already exists, it is first to be unset
-D Reserved for future use.
-H Provide UNIX to hostname file mapping on non-UNIX machines.
-L Left justify and remove leading blanks from value. If n is non-
zero it defines the width of the field. Otherwise, it is deter‐
mined by the width of the value of first assignment. When the
variable is assigned to, it is filled on the right with blanks or
truncated, if necessary, to fit into the field. Leading zeros are
removed if the -Z flag is also set. The -R flag is turned off.
-R Right justify and fill with leading blanks. If n is non-zero it
defines the width of the field, otherwise it is determined by the
width of the value of first assignment. The field is left filled
with blanks or truncated from the end if the variable is reas‐
signed. The -L flag is turned off.
-Z Right justify and fill with leading zeros if the first non-blank
character is a digit and the -L flag has not been set. If n is
non-zero it defines the width of the field. Otherwise, it is
determined by the width of the value of first assignment.
-f All uppercase characters are converted to lowercase. The upper‐
case flag, -u is turned off.
The FPATH variable is searched to find the function definition
when the function is referenced. The flag -x allows the function
definition to remain in effect across shell procedures invoked by
name.
-i Parameter is an integer. This makes arithmetic faster. If n is
non-zero it defines the output arithmetic base. Otherwise, the
first assignment determines the output base.
-l All uppercase characters are converted to lowercase. The upper‐
case flag, -u is turned off.
-m Move. The value is the name of a variable whose value is moved to
name. The original variable is unset. Cannot be used with any
other options.
-r The specified names are marked read-only and these names cannot
be changed by subsequent assignment.
-t Tags the variables. Tags are user definable and have no special
meaning to the shell.
-u All lowercase characters are converted to uppercase characters.
The lowercase flag, -l is turned off.
-x The specified names are marked for automatic export to the envi‐
ronment of subsequently-executed commands.
The i attribute can not be specified along with -R, -L, -Z, or -f.
Using + rather than - causes these flags to be turned off. If no name
arguments are specified but flags are specified, a list of names (and
optionally the values) of the variables which have these flags set is
printed. Using + rather than - keeps the values from being printed. If
no names and flags are specified, the names and attributes of all vari‐
ables are printed.
For each name, whence indicates how it would be interpreted if used as
a command name.
The -v flag produces a more verbose report.
The -p flag does a path search for name even if name is an alias, a
function, or a reserved word.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/core-os
SEE ALSO
ksh(1), ksh88(1), set(1), sh(1s), attributes(7)
Oracle Solaris 11.4 4 Jun 2020 typeset(1)