svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
touchline(3curses)
curs_touch(3CURSES) Curses Library Functions curs_touch(3CURSES)
NAME
curs_touch, touchwin, touchline, untouchwin, wtouchln, is_linetouched,
is_wintouched - curses refresh control routines
SYNOPSIS
cc [ flag ... ] file ... -lcurses [ library ... ]
#include <curses.h>
int touchwin(WINDOW *win);
int touchline(WINDOW *win, int start, int count);
int untouchwin(WINDOW *win);
int wtouchln(WINDOW *win, int y, int n, int changed);
int is_linetouched(WINDOW *win, int line);
int is_wintouched(WINDOW *win);
DESCRIPTION
The touchwin() and touchline() routines throw away all optimization
information about which parts of the window have been touched, by pre‐
tending that the entire window has been drawn on. This is sometimes
necessary when using overlapping windows, since a change to one window
affects the other window, but the records of which lines have been
changed in the other window do not reflect the change. The routine
touchline() only pretends that count lines have been changed, beginning
with line start.
The untouchwin() routine marks all lines in the window as unchanged
since the last call to wrefresh().
The wtouchln() routine makes n lines in the window, starting at line
y, look as if they have (changed=1) or have not (changed=0) been
changed since the last call to wrefresh().
The is_linetouched() and is_wintouched() routines return TRUE if the
specified line/window was modified since the last call to wrefresh();
otherwise they return FALSE. In addition, is_linetouched() returns ERR
if line is not valid for the given window.
RETURN VALUES
All routines return the integer ERR upon failure and an integer value
other than ERR upon successful completion, unless otherwise noted in
the preceding routine descriptions.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelUnsafe
SEE ALSO
curs_refresh(3CURSES), curses(3CURSES), attributes(7)
NOTES
The header <curses.h> automatically includes the headers <stdio.h> and
<unctrl.h>.
Note that all routines except wtouchln() may be macros.
Oracle Solaris 11.4 31 Dec 1996 curs_touch(3CURSES)