svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tolower(3c)
Standard C Library Functions tolower(3C)
NAME
tolower, tolower_l - transliterate uppercase characters to lowercase
SYNOPSIS
#include <ctype.h>
int tolower(int c);
int tolower_l(int c, locale_t locale);
DESCRIPTION
The tolower() and tolower_l() functions have as a domain a type int,
the value of which is representable as an unsigned char or the value of
EOF. If the argument has any other value, the argument is returned
unchanged. The tolower() function operates in the current locale as set
by setlocale(3C), while tolower_l() uses the locale represented by the
locale argument.
If the argument of tolower() or tolower_l() represents an uppercase
letter, and there exists a corresponding lowercase letter as defined by
character type information in the locale category LC_CTYPE, the result
is the corresponding lowercase letter. All other arguments in the
domain are returned unchanged.
The behavior is undefined if the locale argument to tolower_l() is the
special locale object LC_GLOBAL_LOCALE or is not a valid locale object
handle.
RETURN VALUES
On successful completion, tolower() and tolower_l() return the lower‐
case letter corresponding to the argument passed. Otherwise, they
return the argument unchanged.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityStandard _ MT-LevelMT-
Safe
SEE ALSO
_tolower(3C), toupper(3C), duplocale(3C), freelocale(3C), newlo‐
cale(3C), setlocale(3C), uselocale(3C), attributes(7), standards(7)
Oracle Solaris 11.4 11 May 2021 tolower(3C)