thread_exit(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

thread_exit(9)

THREAD_EXIT(9)           BSD Kernel Developer's Manual          THREAD_EXIT(9)

NAME
     thread_exit — abandon current thread context

SYNOPSIS
     #include <sys/param.h>
     #include <sys/proc.h>

     void
     thread_exit(void);

DESCRIPTION
     The thread_exit() function implements the machine independent prelude to
     a thread shutdown.  It will not return, and will result in a call to
     mi_switch(9) to schedule some other thread.

     thread_exit() arranges to free all the resources of the thread, specifi‐
     cally the kernel stack.

     To protect the runqueue(9), thread_exit() must be called with the
     sched_lock mutex held.

SEE ALSO
     mi_switch(9), mutex(9), runqueue(9), sleep(9)

BSD                              July 5, 2002                              BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3