svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
thr_kill(3c)
Standard C Library Functions thr_kill(3C)
NAME
thr_kill - send a signal to a thread
SYNOPSIS
#include <signal.h>
#include <thread.h>
int thr_kill(thread_t thread, int sig);
DESCRIPTION
The thr_kill() function sends the sig signal to the thread designated
by thread. The thread argument must be a member of the same process as
the calling thread. The sig argument must be one of the signals listed
in signal.h(3HEAD), with the exception of SIGCANCEL being reserved and
off limits to thr_kill(). If sig is 0, a validity check is done for the
existence of the target thread; no signal is sent.
RETURN VALUES
Upon successful completion, thr_kill() returns 0. Otherwise, an error
number is returned. In the event of failure, no signal is sent. It is
not an error for the target thread to be a zombie thread.
ERRORS
The thr_kill() function will fail if:
EINVAL The sig argument value is not zero and is an invalid or an
unsupported signal number.
ESRCH No thread was found that corresponded to the thread desig‐
nated by thread ID.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelAsync-Signal-Safe
SEE ALSO
kill(2), sigaction(2), raise(3C), thr_self(3C), signal.h(3HEAD),
attributes(7), standards(7)
Oracle Solaris 11.4 23 Dec 2014 thr_kill(3C)