svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
thr_getprio(3c)
Standard C Library Functions thr_getprio(3C)
NAME
thr_getprio, thr_setprio - access dynamic thread scheduling
SYNOPSIS
#include <thread.h>
int thr_setprio(thread_t target_thread, int priority);
int thr_getprio(thread_t target_thread, int *priority);
DESCRIPTION
The thr_setprio() function sets the scheduling priority for the thread
specified by target_thread within the current process to the value
given by priority.
The thr_getprio() function stores the current priority for the thread
specified by target_thread in the location pointed to by priority.
If the thr_setprio() function fails, the scheduling priority of the
target thread is not changed.
See priocntl(2), pthread_setschedprio(3C), and sched_setparam(3C).
RETURN VALUES
If successful, the thr_getprio() and thr_setprio() functions return 0.
Otherwise, an error number is returned to indicate the error. It is not
an error for the target thread to be a zombie thread.
ERRORS
The thr_getprio() and thr_setprio() functions will fail if:
ESRCH The value specified by target_thread does not refer to an
existing thread.
The thr_setprio() function will fail if:
EINVAL The value of priority is invalid for the scheduling policy of
the specified thread.
EPERM The caller does not have the appropriate permission to set
the priority to the value specified.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
priocntl(2), pthread_setschedprio(3C), sched_setparam(3C), thr_cre‐
ate(3C), thr_suspend(3C), thr_yield(3C), attributes(7), standards(7)
Oracle Solaris 11.4 23 Dec 2014 thr_getprio(3C)