svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcsetpgrp(3c)
Standard C Library Functions tcsetpgrp(3C)
NAME
tcsetpgrp - set foreground process group ID
SYNOPSIS
#include <sys/types.h>
#include <unistd.h>
int tcsetpgrp(int fildes, pid_t pgid_id);
DESCRIPTION
If the process has a controlling terminal, tcsetpgrp() will set the
foreground process group ID associated with the terminal to pgid_id.
The file associated with fildes must be the controlling terminal of the
calling process and the controlling terminal must be currently associ‐
ated with the session of the calling process. The value of pgid_id must
match a process group ID of a process in the same session as the call‐
ing process.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The tcsetpgrp() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
EINVAL This implementation does not support the value in the pgid_id
argument.
ENOTTY The calling process does not have a controlling terminal, or
the file is not the controlling terminal, or the controlling
terminal is no longer associated with the session of the
calling process.
EIO The process is not ignoring or holding SIGTTOU and is a mem‐
ber of an orphaned process group.
EPERM The value of pgid_id does not match the process group ID of a
process in the same session as the calling process.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
tcgetpgrp(3C), termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcsetpgrp(3C)