svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcsendbreak(3c)
Standard C Library Functions tcsendbreak(3C)
NAME
tcsendbreak - send a "break" for a specific duration
SYNOPSIS
#include <termios.h>
int tcsendbreak(int fildes, int duration);
DESCRIPTION
The fildes argument is an open file descriptor associated with a termi‐
nal.
If the terminal is using asynchronous serial data transmission, tcsend‐
break() will cause transmission of a continuous stream of zero-valued
bits for a specific duration. If duration is 0, it will cause transmis‐
sion of zero-valued bits for at least 0.25 seconds, and not more than
0.5 seconds. If duration is not 0, it behaves in a way similar to
tcdrain(3C).
If the terminal is not using asynchronous serial data transmission, it
sends data to generate a break condition or returns without taking any
action.
Attempts to use tcsendbreak() from a process which is a member of a
background process group on a fildes associated with its controlling
terminal will cause the process group to be sent a SIGTTOU signal. If
the calling process is blocking or ignoring SIGTTOU signals, the
process is allowed to perform the operation, and no signal is sent.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The tcsendbreak() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
ENOTTY The file associated with fildes is not a terminal.
The tcsendbreak() function may fail if:
EIO The process group of the writing process is orphaned, and the
writing process is not ignoring or blocking SIGTTOU.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
tcdrain(3C), termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcsendbreak(3C)