svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcgetsid(3c)
Standard C Library Functions tcgetsid(3C)
NAME
tcgetsid - get process group ID for session leader for controlling ter‐
minal
SYNOPSIS
#include <termios.h>
pid_t tcgetsid(int fildes);
DESCRIPTION
The tcgetsid() function obtains the process group ID of the session for
which the terminal specified by fildes is the controlling terminal.
RETURN VALUES
Upon successful completion, tcgetsid() returns the process group ID
associated with the terminal. Otherwise, a value of (pid_t)−1 is
returned and errno is set to indicate the error.
ERRORS
The tcgetsid() function will fail if:
EACCES The fildes argument is not associated with a controlling ter‐
minal.
EBADF The fildes argument is not a valid file descriptor.
ENOTTY The file associated with fildes is not a terminal.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcgetsid(3C)