svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcgetpgrp(3c)
Standard C Library Functions tcgetpgrp(3C)
NAME
tcgetpgrp - get foreground process group ID
SYNOPSIS
#include <sys/types.h>
#include <unistd.h>
pid_t tcgetpgrp(int fildes);
DESCRIPTION
The tcgetpgrp() function will return the value of the process group ID
of the foreground process group associated with the terminal.
If there is no foreground process group, tcgetpgrp() returns a value
greater than 1 that does not match the process group ID of any existing
process group.
The tcgetpgrp() function is allowed from a process that is a member of
a background process group; however, the information may be subse‐
quently changed by a process that is a member of a foreground process
group.
RETURN VALUES
Upon successful completion, tcgetpgrp() returns the value of the
process group ID of the foreground process associated with the termi‐
nal. Otherwise, −1 is returned and errno is set to indicate the error.
ERRORS
The tcgetpgrp() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
ENOTTY The calling process does not have a controlling terminal, or
the file is not the controlling terminal.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
setpgid(2), setsid(2), tcsetpgrp(3C), termio(4I), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 14 Aug 2002 tcgetpgrp(3C)