svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcgetattr(3c)
Standard C Library Functions tcgetattr(3C)
NAME
tcgetattr - get the parameters associated with the terminal
SYNOPSIS
#include <termios.h>
int tcgetattr(int fildes, struct termios *termios_p);
DESCRIPTION
The tcgetattr() function gets the parameters associated with the termi‐
nal referred to by fildes and stores them in the termios structure (see
termio(4I)) referenced by termios_p. The fildes argument is an open
file descriptor associated with a terminal.
The termios_p argument is a pointer to a termios structure.
The tcgetattr() operation is allowed from any process.
If the terminal device supports different input and output baud rates,
the baud rates stored in the termios structure returned by tcgetattr()
reflect the actual baud rates, even if they are equal. If differing
baud rates are not supported, the rate returned as the output baud rate
is the actual baud rate. If the terminal device does not support split
baud rates, the input baud rate stored in the termios structure will be
0.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The tcgetattr() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
ENOTTY The file associated with fildes is not a terminal.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
tcsetattr(3C), termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcgetattr(3C)