svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcflush(3c)
Standard C Library Functions tcflush(3C)
NAME
tcflush - flush non-transmitted output data, non-read input data or
both
SYNOPSIS
#include <termios.h>
int tcflush(int fildes, int queue_selector);
DESCRIPTION
Upon successful completion, tcflush() discards data written to the
object referred to by fildes (an open file descriptor associated with a
terminal) but not transmitted, or data received but not read, depending
on the value of queue_selector:
o If queue_selector is TCIFLUSH it flushes data received but
not read.
o If queue_selector is TCOFLUSH it flushes data written but
not transmitted.
o If queue_selector is TCIOFLUSH it flushes both data received
but not read and data written but not transmitted.
Attempts to use tcflush() from a process which is a member of a back‐
ground process group on a fildes associated with its controlling termi‐
nal, will cause the process group to be sent a SIGTTOU signal. If the
calling process is blocking or ignoring SIGTTOU signals, the process is
allowed to perform the operation, and no signal is sent.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The tcflush() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
EINVAL The queue_selector argument is not a supported value.
ENOTTY The file associated with fildes is not a terminal.
The tcflush() function may fail if:
EIO The process group of the writing process is orphaned, and the
writing process is not ignoring or blocking SIGTTOU.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
tcdrain(3C), termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcflush(3C)