svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
tcflow(3c)
Standard C Library Functions tcflow(3C)
NAME
tcflow - suspend or restart the transmission or reception of data
SYNOPSIS
#include <termios.h>
int tcflow(int fildes, int action);
DESCRIPTION
The tcflow() function suspends transmission or reception of data on the
object referred to by fildes, depending on the value of action. The
fildes argument is an open file descriptor associated with a terminal.
o If action is TCOOFF, output is suspended.
o If action is TCOON, suspended output is restarted.
o If action is TCIOFF, the system transmits a STOP character,
which is intended to cause the terminal device to stop
transmitting data to the system.
o If action is TCION, the system transmits a START character,
which is intended to cause the terminal device to start
transmitting data to the system.
The default on the opening of a terminal file is that neither its input
nor its output are suspended.
Attempts to use tcflow() from a process which is a member of a back‐
ground process group on a fildes associated with its controlling termi‐
nal, will cause the process group to be sent a SIGTTOU signal. If the
calling process is blocking or ignoring SIGTTOU signals, the process is
allowed to perform the operation, and no signal is sent.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The tcflow() function will fail if:
EBADF The fildes argument is not a valid file descriptor.
EINVAL The action argument is not a supported value.
ENOTTY The file associated with fildes is not a terminal.
The tcflow() function may fail if:
EIO The process group of the writing process is orphaned, and the
writing process is not ignoring or blocking SIGTTOU.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe, and
Async-Signal-Safe _ StandardSee standards(7).
SEE ALSO
tcsendbreak(3C), termio(4I), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 tcflow(3C)