svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
strxfrm_l(3c)
Standard C Library Functions strxfrm(3C)
NAME
strxfrm, strxfrm_l - string transformation
SYNOPSIS
#include <string.h>
size_t strxfrm(char *restrict s1, const char *restrict s2, size_t n);
size_t strxfrm_l(char *restrict s1, const char *restrict s2, size_t n, locale_t locale);
DESCRIPTION
The strxfrm() and strxfrm_l() functions transform the string pointed to
by s2 and places the resulting string into the array pointed to by s1.
The transformation is such that if strcmp(3C) is applied to two trans‐
formed strings, it returns a value greater than, equal to or less than
0, corresponding to the result of strcoll(3C) or strcoll_l(3C), respec‐
tively, applied to the same two original strings with the same locale.
No more than n bytes are placed into the resulting array pointed to by
s1, including the terminating null byte. If n is 0, s1 is permitted to
be a null pointer. If copying takes place between objects that overlap,
the behavior is undefined.
The strxfrm() and strxfrm_l() functions do not change the setting of
errno if successful.
Since no return value is reserved to indicate an error, an application
wishing to check for error situations should set errno to 0, then call
strxfrm() or strxfrm_l(), then check errno.
RETURN VALUES
Upon successful completion, strxfrm() and strxfrm_l() return the length
of the transformed string (not including the terminating null byte). If
the value returned is n or more, the contents of the array pointed to
by s1 are indeterminate.
On error, strxfrm() and strxfrm_l() may set errno but no return value
is reserved to indicate the error.
USAGE
The transformation function is such that two transformed strings can be
ordered by strcmp(3C) as appropriate to collating sequence information
in category LC_COLLATE of current locale for strxfrm() or of locale
represented by locale for strxfrm_l() respectively.
The fact that when n is 0, s1 is permitted to be a null pointer, is
useful to determine the size of the s1 array prior to making the trans‐
formation.
EXAMPLES
Example 1 A sample of using the strxfm() function.
The value of the following expression is the size of the array needed
to hold the transformation of the string pointed to by s.
1 + strxfrm(NULL, s, 0);
FILES
/usr/lib/locale/locale/locale.so.*
LC_COLLATE database for locale
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityCommitted _ MT-LevelMT-
Safe _ StandardSee standards(7).
SEE ALSO
wscoll(3C), localedef(1), duplocale(3C), freelocale(3C), newlocale(3C),
setlocale(3C), strcmp(3C), strcoll(3C), uselocale(3C), attributes(7),
environ(7), standards(7)
Oracle Solaris 11.4 9 Oct 2014 strxfrm(3C)