store(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

store(9)

STORE(9)                 BSD Kernel Developer's Manual                STORE(9)

NAME
     store, subyte, suword — store data to user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>

     int
     subyte(volatile void *base, int byte);

     int
     suword(volatile void *base, long word);

     int
     suword16(volatile void *base, int word);

     int
     suword32(volatile void *base, int32_t word);

     int
     suword64(volatile void *base, int64_t word);

     #include <sys/resourcevar.h>

DESCRIPTION
     The store functions are designed to copy small amounts of data to user-
     space.  If write is successful, it is performed atomically.  The data
     written must be naturally aligned.

     The store routines provide the following functionality:

     subyte()    Stores a byte of data to the user-space address base.

     suword()    Stores a word of data to the user-space address base.

     suword16()  Stores 16 bits of data to the user-space address base.

     suword32()  Stores 32 bits of data to the user-space address base.

     suword64()  Stores 64 bits of data to the user-space address base.

RETURN VALUES
     The store functions return 0 on success or -1 on failure.

SEE ALSO
     copy(9), fetch(9)

BSD                             April 17, 2018                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3