svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
stack_getbounds(3c)
Standard C Library Functions stack_getbounds(3C)
NAME
stack_getbounds - retrieve stack boundaries
SYNOPSIS
#include <ucontext.h>
int stack_getbounds(stack_t *sp);
DESCRIPTION
The stack_getbounds() function retrieves the stack boundaries that the
calling thread is currently operating on. If the thread is currently
operating on the alternate signal stack, this function will retrieve
the bounds of that stack.
If successful, stack_getbounds() sets the ss_sp member of the stack_t
structure pointed to by sp to the base of the stack region and the
ss_size member to its size (maximum extent) in bytes. The ss_flags mem‐
ber is set to SS_ONSTACK if the calling thread is executing on its
alternate signal stack, and zero otherwise.
RETURN VALUES
Upon successful completion, stack_getbounds() returns 0. Otherwise, −1
is returned and errno is set to indicate the error.
ERRORS
The stack_getbounds() function will fail if:
EFAULT The sp argument does not refer to a valid address.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe
SEE ALSO
getustack(2), sigaction(2), sigaltstack(2), stack_setbounds(3C),
attributes(7)
Oracle Solaris 11.4 18 Jul 2002 stack_getbounds(3C)