svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sstore_info_read(3sstore)
Solaris Statistics Store Library Functions sstore_info_read(3SSTORE)
NAME
sstore_info_read, sstore_info_iter_next - Read meta information about
statistics store identifiers.
SYNOPSIS
cc [ flag... ] file... -lsstore [ library... ]
#include <libsstore.h>
sstore_err_t sstore_info_read(sstore_handle_t hdl,
const char **ids, uint32_t id_count,
sstore_range_t range, sstore_iter_t *iterp);
sstore_err_t sstore_info_iter_next(sstore_handle_t hdl,
sstore_iter_t iter, char **idp, uint64_t *timep,
sstore_value_t *valp);
PARAMETERS
hdl Handle to libsstore
ids Array of statistics store identifiers
id_count Total number of statistics store identifiers
range Time range or data range.
Passing NULL for range implies:
o start-time = SS_TIME_NOW
o end-time = SS_TIME_NOW
o step = 1
iterp Address to store the starting address of the iterator.
iter Iterator returned from data_read().
idp Address to store the starting address of the statistics
store identifier.
timep Address to store the time in microseconds since epoch.
valp Address to store the handle to a typed value.
DESCRIPTION
sstore_info_read() retrieves the metadata associated with the given
identifiers and range. The retrieved data is returned in the form of an
iterator that can be used to read the information records. When all the
information records have been read from the iterator, use
sstore_iter_free(3SSTORE) to free the iterator.
sstore_info_iter_next() retrieves the next information record of the
iteration. Each information record consists of a statistics store iden‐
tifier, a time stamp, and a value. The reference pointers passed to
this call are populated if the call succeeds. The identifier, the time
stamp, and the value populated on success do not need to be freed. They
will be freed on the next call to sstore_info_iter_next().
RETURN VALUES
Upon successful completion, sstore_info_read() and
sstore_info_iter_next() return ESSTORE_OK. Otherwise, they return an
error code, which is also cached in the given libsstore handle.
ERRORS
The sstore_info_read() function will fail if:
ESSTORE_ARG_INVALID One of the following reasons:
o All the ssids are invalid.
o All the ssids are inactive.
o The range is not valid.
o The fmt is not valid.
o Required arguments are missing.
ESSTORE_HANDLE_INVALID The handle is invalid
ESSTORE_RETRY The statistics store daemon is busy. Retry
later
ESSTORE_CONNECTION_FAILED Failed to connect to the statistics store
daemon
ESSTORE_TOO_BIG The total size of all the resulting sta‐
tistics records is larger than the maximum
size limit set in libsstore.
ESSTORE_NOMEM No memory is available.
The sstore_info_iter_next() function will fail if:
ESSTORE_ARG_INVALID Some arguments are invalid.
ESSTORE_HANDLE_INVALID The handle is invalid
ESSTORE_ITER_DONE No more records left to iterate.
WARNINGS
Possible warning codes for sstore_info_read() are as follows:
SS_WARN_INVALID An ssid is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libsstore(3LIB), sstore_alloc(3SSTORE), sstore_err_action(3SSTORE),
sstore_range_alloc(3SSTORE), attributes(7), ssid(7)
Oracle Solaris 11.4 09 Dec 2015 sstore_info_read(3SSTORE)