svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sockatmark(3c)
Standard C Library Functions sockatmark(3C)
NAME
sockatmark - determine whether a socket is at the out-of-band mark
SYNOPSIS
#include <sys/socket.h>
int sockatmark(int s);
DESCRIPTION
The sockatmark() function determines whether the socket specified by
the descriptor s is at the out-of-band data mark. If the protocol for
the socket supports out-of-band data by marking the stream with an out-
of-band data mark, the sockatmark() function returns 1 when all data
preceding the mark has been read and the out-of-band data mark is the
first element in the receive queue. The sockatmark() function does not
remove the mark from the stream.
RETURN VALUES
Upon successful completion, the sockatmark() function returns a value
indicating whether the socket is at an out-of-band data mark. If the
protocol has marked the data stream and all data preceding the mark has
been read, the return value is 1. If there is no mark, or if data pre‐
cedes the mark in the receive queue, the sockatmark() function returns
0. Otherwise, it returns −1 and sets errno to indicate the error.
ERRORS
The sockatmark() function will fail if:
EBADF The s argument is not a valid file descriptor.
ENOTTY The s argument does not specify a descriptor for a socket.
USAGE
The use of this function between receive operations allows an applica‐
tion to determine which received data precedes the out-of-band data and
which follows the out-of-band data.
There is an inherent race condition in the use of this function. On an
empty receive queue, the current read of the location might well be at
the "mark", but the system has no way of knowing that the next data
segment that will arrive from the network will carry the mark, and
sockatmark() will return false, and the next read operation will
silently consume the mark.
Hence, this function can only be used reliably when the application
already knows that the out-of-band data has been seen by the system or
that it is known that there is data waiting to be read at the socket,
either by SIGURG or select(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
recv(3C), recvmsg(3C), select(3C), attributes(7), standards(7)
HISTORY
The sockatmark() function was added to Oracle Solaris in the Solaris 10
3/05 release.
Oracle Solaris 11.4 2 Feb 2021 sockatmark(3C)