svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sleep(3c)
Standard C Library Functions sleep(3C)
NAME
sleep - suspend execution for an interval of time
SYNOPSIS
#include <unistd.h>
unsigned int sleep(unsigned int seconds);
DESCRIPTION
The caller is suspended from execution for the number of seconds speci‐
fied by the argument. The actual suspension time may be less than that
requested because any caught signal will terminate the sleep() follow‐
ing execution of that signal's catching routine. The suspension time
may be longer than requested by an arbitrary amount because of the
scheduling of other activity in the system. The value returned by
sleep() will be the "unslept" amount (the requested time minus the time
actually slept) if the caller is woken early by the delivery of a sig‐
nal.
The use of the sleep() function has no effect on the action or blockage
of any signal. In a multithreaded process, only the invoking thread is
suspended from execution.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
nanosleep(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Nov 2020 sleep(3C)