svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
shutdown(3c)
Standard C Library Functions shutdown(3C)
NAME
shutdown - shut down socket send and receive operations
SYNOPSIS
#include <sys/socket.h>
int shutdown(int socket, int how);
DESCRIPTION
The shutdown() function disables subsequent send and receive operations
on a socket, depending on the value of the how argument.
PARAMETERS
how Specifies the type of shutdown. The values are as follows:
SHUT_RD Disables further receive operations.
SHUT_WR Disables further send operations.
SHUT_RDWR Disables further send and receive operations.
socket Specifies the file descriptor of the socket.
RETURN VALUES
Upon successful completion, shutdown() returns 0. Otherwise, −1 is
returned and errno is set to indicate the error.
ERRORS
The shutdown() function will fail if:
EBADF The socket argument is not a valid file descriptor.
EINVAL The how argument is invalid.
ENOTCONN The socket is not connected.
ENOTSOCK The socket argument does not refer to a socket.
The shutdown() function may fail if:
ENOBUFS Insufficient resources were available in the system to per‐
form the operation.
ENOSR There were insufficient STREAMS resources available for the
operation to complete.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
getsockopt(3C), recv(3C), recvfrom(3C), recvmsg(3C), recvmmsg(3C),
select(3C), send(3C), sendfile(3C), sendfilev(3C), sendmsg(3C), send‐
mmsg(3C), sendto(3C), setsockopt(3C), socket(3C), attributes(7), stan‐
dards(7)
HISTORY
The shutdown() function has been present since the initial release of
Solaris.
Oracle Solaris 11.4 2 Feb 2021 shutdown(3C)