svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sem_unlink(3c)
Standard C Library Functions sem_unlink(3C)
NAME
sem_unlink - remove a named semaphore
SYNOPSIS
#include <semaphore.h>
int sem_unlink(const char *name);
DESCRIPTION
The sem_unlink() function removes the semaphore named by the string
name. If the semaphore named by name is currently referenced by other
processes, then sem_unlink() has no effect on the state of the sema‐
phore. If one or more processes have the semaphore open when
sem_unlink() is called, destruction of the semaphore is postponed until
all references to the semaphore have been destroyed by calls to
sem_close(3C), _Exit(2), or one of the exec functions (see exec(2)) .
Calls to sem_open(3C) to re-create or re-connect to the semaphore refer
to a new semaphore after sem_unlink() is called. The sem_unlink() call
does not block until all references have been destroyed; it returns
immediately.
RETURN VALUES
Upon successful completion, sem_unlink() returns 0. Otherwise, the sem‐
aphore is not changed and the function returns a value of −1 and sets
errno to indicate the error.
ERRORS
The sem_unlink() function will fail if:
EACCES Permission is denied to unlink the named semaphore.
ENAMETOOLONG The length of name string exceeds PATH_MAX, or a path‐
name component is longer than NAME_MAX while
_POSIX_NO_TRUNC is in effect.
ENOENT The named semaphore does not exist.
ENOSYS The sem_unlink() function is not supported by the sys‐
tem.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
exec(2), exit(2), sem_close(3C), sem_open(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 31 Jan 2012 sem_unlink(3C)