svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sem_getvalue(3c)
Standard C Library Functions sem_getvalue(3C)
NAME
sem_getvalue - get the value of a semaphore
SYNOPSIS
#include <semaphore.h>
int sem_getvalue(sem_t *restrict sem, int *restrict sval);
DESCRIPTION
The sem_getvalue() function updates the location referenced by the sval
argument to have the value of the semaphore referenced by sem without
affecting the state of the semaphore. The updated value represents an
actual semaphore value that occurred at some unspecified time during
the call, but it need not be the actual value of the semaphore when it
is returned to the calling process.
If sem is locked, then the value returned by sem_getvalue() is either
zero or a negative number whose absolute value represents the number of
processes waiting for the semaphore at some unspecified time during the
call.
The value set in sval may be 0 or positive. If sval is 0, there may be
other processes (or LWPs or threads) waiting for the semaphore; if sval
is positive, no process is waiting.
RETURN VALUES
Upon successful completion, sem_getvalue() returns 0. Otherwise, it
returns −1 and sets errno to indicate the error.
ERRORS
The sem_getvalue() function will fail if:
EINVAL The sem argument does not refer to a valid semaphore.
ENOSYS The sem_getvalue() function is not supported by the system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
semctl(2), semget(2), semop(2), sem_post(3C), sem_wait(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 5 Feb 2008 sem_getvalue(3C)