svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
scsi_hba_pkt_comp(9f)
scsi_hba_pkt_comp(9F) Kernel Functions scsi_hba_pkt_comp(9F)
NAME
scsi_hba_pkt_comp - scsi_pkt completion routine
SYNOPSIS
#include <sys/scsi/scsi.h>
void scsi_hba_pkt_comp(struct scsi_pkt *pkt);
PARAMETERS
pkt Pointer to a scsi_pkt(9S) structure.
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
After filling in scsi_pkt(9S) fields with packet completion informa‐
tion, an HBA driver should call the scsi_hba_pkt_comp() function. This
function is the recommended way for an HBA driver to signal completion
of a scsi_pkt structure. Use is mandatory for HBA drivers that use
tran_setup_pkt(9E).
Calling the scsi_hba_pkt_comp() function allows SCSA to observe, and
possibly react to, the completion of a scsi_pkt request.
A call to the scsi_hba_pkt_comp() function will always result in a call
to the pkt_comp() callback function defined in scsi_pkt(9S). This
pkt_comp() callback may, however, occur after return from
scsi_hba_pkt_comp(), and may occur from a different thread executing on
a different CPU.
CONTEXT
The scsi_hba_pkt_comp() function can be called from user, interrupt, or
kernel context.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted
SEE ALSO
attributes(7), tran_setup_pkt(9E), scsi_pkt(9S)
NOTES
HBA driver calls scsi_hba_pkt_comp() instead of calling scsi_pkt(9S)
pkt_comp directly.
Oracle Solaris 11.4 29 Jan 2009 scsi_hba_pkt_comp(9F)