scsi_hba_lookup_capstr(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

scsi_hba_lookup_capstr(9f)

Kernel Functions                                    scsi_hba_lookup_capstr(9F)



NAME
       scsi_hba_lookup_capstr - return index matching capability string

SYNOPSIS
       #include <sys/scsi/scsi.h>

       int scsi_hba_lookup_capstr(char *capstr);

INTERFACE LEVEL
       Solaris architecture specific (Solaris DDI).

PARAMETERS
       capstr    Pointer to a string


DESCRIPTION
       The  scsi_hba_lookup_capstr() function attempts to match capstr against
       a known set of capability strings. If found, the defined index for  the
       matched capability is returned.


       The  following  indices  are  defined for the capability strings listed
       below.

       SCSI_CAP_DMA_MAX

           "dma-max" or "dma_max"


       SCSI_CAP_MSG_OUT

           "msg-out" or "msg_out"


       SCSI_CAP_DISCONNECT

           "disconnect"


       SCSI_CAP_SYNCHRONOUS

           "synchronous"


       SCSI_CAP_WIDE_XFER

           "wide-xfer" or "wide_xfer"


       SCSI_CAP_PARITY

           "parity"


       SCSI_CAP_INITIATOR_ID

           "initiator-id"


       SCSI_CAP_UNTAGGED_QING

           "untagged-qing"


       SCSI_CAP_TAGGED_QING

           "tagged-qing"


       SCSI_CAP_ARQ

           "auto-rqsense"


       SCSI_CAP_LINKED_CMDS

           "linked-cmds"


       SCSI_CAP_SECTOR_SIZE

           "sector-size"


       SCSI_CAP_TOTAL_SECTORS

           "total-sectors"


       SCSI_CAP_GEOMETRY

           "geometry"


       SCSI_CAP_RESET_NOTIFICATION

           "reset-notification"


       SCSI_CAP_QFULL_RETRIES

           "qfull-retries"


       SCSI_CAP_QFULL_RETRY_INTERVAL

           "qfull-retry-interval"


       SCSI_CAP_LUN_RESET

           "lun-reset"


       SCSI_CAP_CDB_LEN

           "max-cdb-length"


       SCSI_CAP_TRAN_LAYER_RETRIES

           "tran-layer-retries"


RETURN VALUES
       The scsi_hba_lookup_capstr()  function  returns  a  non-negative  index
       value that corresponds to the capability string. If the string does not
       match a known capability, -1 is returned.

CONTEXT
       The scsi_hba_lookup_capstr() function can be called from  user,  inter‐
       rupt, or kernel context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Interface StabilityCommitted


SEE ALSO
       tran_getcap(9E), tran_setcap(9E), scsi_ifgetcap(9F), scsi_ifsetcap(9F),
       scsi_reset_notify(9F)


       Writing Device Drivers in Oracle Solaris 11.4



Oracle Solaris 11.4               29 Oct 2009
                                                    scsi_hba_lookup_capstr(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3