svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sched_setscheduler(3c)
Standard C Library Functions sched_setscheduler(3C)
NAME
sched_setscheduler - set scheduling policy and scheduling parameters
SYNOPSIS
#include <sched.h>
int sched_setscheduler(pid_t pid, int policy,
const struct sched_param *param);
DESCRIPTION
The sched_setscheduler() function sets the scheduling policy and sched‐
uling parameters of the process specified by pid to policy and the
parameters specified in the sched_param structure pointed to by param,
respectively. The value of the sched_priority member in the sched_param
structure is any integer within the inclusive priority range for the
scheduling policy specified by policy. The sched_setscheduler() func‐
tion ignores the other members of the sched_param structure. If the
value of pid is negative, the behavior of the sched_setscheduler()
function is unspecified.
The possible values for the policy parameter are defined in the header
<sched.h> (see sched.h(3HEAD)):
If a process specified by pid exists and if the calling process has
permission, the scheduling policy and scheduling parameters are set for
the process whose process ID is equal to pid. The real or effective
user ID of the calling process must match the real or saved (from
exec(2)) user ID of the target process unless the effective user ID of
the calling process is 0. See Intro(2).
If pid is 0, the scheduling policy and scheduling parameters are set
for the calling process.
To change the policy of any process to either of the real time policies
SCHED_FIFO or SCHED_RR, the calling process must either have the
SCHED_FIFO or SCHED_RR policy or have an effective user ID of 0.
The sched_setscheduler() function is considered successful if it suc‐
ceeds in setting the scheduling policy and scheduling parameters of the
process specified by pid to the values specified by policy and the
structure pointed to by param, respectively.
RETURN VALUES
Upon successful completion, the function returns the former scheduling
policy of the specified process. If the sched_setscheduler() function
fails to complete successfully, the policy and scheduling parameters
remain unchanged, and the function returns −1 and sets errno to indi‐
cate the error.
ERRORS
The sched_setscheduler() function will fail if:
EINVAL The value of policy is invalid, or one or more of the parame‐
ters contained in param is outside the valid range for the
specified scheduling policy.
EPERM The requesting process does not have permission to set either
or both of the scheduling parameters or the scheduling policy
of the specified process.
ESRCH No process can be found corresponding to that specified by
pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
priocntl(1), exec(2), Intro(2), priocntl(2), sched_getparam(3C),
sched_get_priority_max(3C), sched_getscheduler(3C), sched_setparam(3C),
sched.h(3HEAD), librt(3LIB), attributes(7), standards(7)
Oracle Solaris 11.4 13 Nov 2020 sched_setscheduler(3C)