svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sched_setparam(3c)
Standard C Library Functions sched_setparam(3C)
NAME
sched_setparam - set scheduling parameters
SYNOPSIS
#include <sched.h>
int sched_setparam(pid_t pid, const struct sched_param *param);
DESCRIPTION
The sched_setparam() function sets the scheduling parameters of the
process specified by pid to the values specified by the sched_param
structure pointed to by param. The value of the sched_priority member
in the sched_param structure is any integer within the inclusive prior‐
ity range for the current scheduling policy of the process specified by
pid. Higher numerical values for the priority represent higher priori‐
ties. If the value of pid is negative, the behavior of the sched_set‐
param() function is unspecified.
If a process specified by pid exists and if the calling process has
permission, the scheduling parameters will be set for the process whose
process ID is equal to pid. The real or effective user ID of the call‐
ing process must match the real or saved (from exec(2)) user ID of the
target process unless the effective user ID of the calling process is
0. See Intro(2).
If pid is zero, the scheduling parameters will be set for the calling
process.
The target process, whether it is running or not running, resumes exe‐
cution after all other runnable processes of equal or greater priority
have been scheduled to run.
If the priority of the process specified by the pid argument is set
higher than that of the lowest priority running process and if the
specified process is ready to run, the process specified by the pid
argument preempts a lowest priority running process. Similarly, if the
process calling sched_setparam() sets its own priority lower than that
of one or more other non-empty process lists, then the process that is
the head of the highest priority list also preempts the calling
process. Thus, in either case, the originating process might not
receive notification of the completion of the requested priority change
until the higher priority process has executed.
RETURN VALUES
If successful, the sched_setparam() function returns 0.
If the call to sched_setparam() is unsuccessful, the priority remains
unchanged, and the function returns −1 and sets errno to indicate the
error.
ERRORS
The sched_setparam() function will fail if:
EINVAL One or more of the requested scheduling parameters is outside
the range defined for the scheduling policy of the specified
pid.
EPERM The requesting process does not have permission to set the
scheduling parameters for the specified process, or does not
have the appropriate privilege to invoke sched_setparam().
ESRCH No process can be found corresponding to that specified by
pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
exec(2), Intro(2), sched_getparam(3C), sched_getscheduler(3C),
sched_setscheduler(3C), sched.h(3HEAD), librt(3LIB), attributes(7),
standards(7)
Oracle Solaris 11.4 1 Apr 2008 sched_setparam(3C)