svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sched_getscheduler(3c)
Standard C Library Functions sched_getscheduler(3C)
NAME
sched_getscheduler - get scheduling policy
SYNOPSIS
#include <sched.h>
int sched_getscheduler(pid_t pid);
DESCRIPTION
The sched_getscheduler() function returns the scheduling policy of the
process specified by pid. If the value of pid is negative, the behavior
of the sched_getscheduler() function is unspecified.
The values that can be returned by sched_getscheduler() are defined in
the header <sched.h> and described on the sched_setscheduler(3C) manual
page.
If a process specified by pid exists and if the calling process has
permission, the scheduling policy will be returned for the process
whose process ID is equal to pid.
If pid is 0, the scheduling policy will be returned for the calling
process.
RETURN VALUES
Upon successful completion, the sched_getscheduler() function returns
the scheduling policy of the specified process. If unsuccessful, the
function returns −1 and sets errno to indicate the error.
ERRORS
The sched_getscheduler() function will fail if:
EPERM The requesting process does not have permission to determine
the scheduling policy of the specified process.
ESRCH No process can be found corresponding to that specified by
pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
sched_getparam(3C), sched_setparam(3C), sched_setscheduler(3C),
sched.h(3HEAD), librt(3LIB), attributes(7), standards(7)
Oracle Solaris 11.4 1 Apr 2008 sched_getscheduler(3C)