svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sched_getparam(3c)
Standard C Library Functions sched_getparam(3C)
NAME
sched_getparam - get scheduling parameters
SYNOPSIS
#include <sched.h>
int sched_getparam(pid_t pid, struct sched_param *param);
DESCRIPTION
The sched_getparam() function returns the scheduling parameters of a
process specified by pid in the sched_param structure pointed to by
param. The only required member of param is sched_priority.
If a process specified by pid exists and if the calling process has
permission, the scheduling parameters for the process whose process ID
is equal to pid will be returned.
If pid is 0, the scheduling parameters for the calling process will be
returned. The behavior of the sched_getparam() function is unspecified
if the value of pid is negative.
RETURN VALUES
Upon successful completion, the sched_getparam() function returns 0. If
the call to sched_getparam() is unsuccessful, the function returns −1
and sets errno to indicate the error.
ERRORS
The sched_getparam() function will fail if:
EPERM The requesting process does not have permission to obtain the
scheduling parameters of the specified process.
ESRCH No process can be found corresponding to that specified by
pid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
sched_getscheduler(3C), sched_setparam(3C), sched_setscheduler(3C),
sched.h(3HEAD), librt(3LIB), attributes(7), standards(7)
Oracle Solaris 11.4 1 Apr 2008 sched_getparam(3C)