svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
sched_get_priority_max(3c)
Standard C Library Functions
sched_get_priority_max(3C)
NAME
sched_get_priority_max, sched_get_priority_min - get scheduling parame‐
ter limits
SYNOPSIS
#include <sched.h>
int sched_get_priority_max(int policy);
int sched_get_priority_min(int policy);
DESCRIPTION
The sched_get_priority_max() and sched_get_priority_min() functions
return the appropriate maximum or minimum, respectfully, for the sched‐
uling policy specified by policy.
The value of policy is one of the scheduling policy values defined in
<sched.h>.
RETURN VALUES
If successful, the sched_get_priority_max() and sched_get_prior‐
ity_min() functions return the appropriate maximum or minimum priority
values, respectively. If unsuccessful, they return −1 and set errno to
indicate the error.
ERRORS
The sched_get_priority_max() and sched_get_priority_min() functions
will fail if:
EINVAL The value of the policy parameter does not represent a
defined scheduling policy.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
sched_getparam(3C), sched_getscheduler(3C), sched_rr_get_interval(3C),
sched_setparam(3C), sched_setscheduler(3C), sched.h(3HEAD),
time.h(3HEAD), librt(3LIB), attributes(7), standards(7)
Oracle Solaris 11.4 1 Apr 2008
sched_get_priority_max(3C)