svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_xdr(3c)
Standard C Library Functions rpc_xdr(3C)
NAME
rpc_xdr, xdr_accepted_reply, xdr_authsys_parms, xdr_callhdr,
xdr_callmsg, xdr_opaque_auth, xdr_rejected_reply, xdr_replymsg - XDR
library routines for remote procedure calls
SYNOPSIS
bool_t xdr_accepted_reply(XDR *xdrs, const struct accepted_reply *ar);
bool_t xdr_authsys_parms(XDR *xdrs, struct authsys_parms *aupp);
void xdr_callhdr(XDR *xdrs, struct rpc_msg *chdr);
bool_t xdr_callmsg(XDR *xdrs, struct rpc_msg *cmsg);
bool_t xdr_opaque_auth(XDR *xdrs, struct opaque_auth *ap);
bool_t xdr_rejected_reply(XDR *xdrs, const struct rejected_reply *rr);
bool_t xdr_replymsg(XDR *xdrs, const struct rpc_msg *rmsg);
DESCRIPTION
These routines are used for describing the RPC messages in XDR lan‐
guage. They should normally be used by those who do not want to use the
RPC package directly. These routines return TRUE if they succeed, FALSE
otherwise.
Routines
See rpc(3C) for the definition of the XDR data structure.
#include <rpc/rpc.h>
xdr_accepted_reply() Used to translate between RPC reply messages and
their external representation. It includes the
status of the RPC call in the XDR language for‐
mat. In the case of success, it also includes the
call results.
xdr_authsys_parms() Used for describing UNIX operating system creden‐
tials. It includes machine-name, uid, gid list,
etc.
xdr_callhdr() Used for describing RPC call header messages. It
encodes the static part of the call message
header in the XDR language format. It includes
information such as transaction ID, RPC version
number, program and version number.
xdr_callmsg() Used for describing RPC call messages. This
includes all the RPC call information such as
transaction ID, RPC version number, program num‐
ber, version number, authentication information,
etc. This is normally used by servers to deter‐
mine information about the client RPC call.
xdr_opaque_auth() Used for describing RPC opaque authentication
information messages.
xdr_rejected_reply() Used for describing RPC reply messages. It
encodes the rejected RPC message in the XDR lan‐
guage format. The message could be rejected
either because of version number mis-match or
because of authentication errors.
xdr_replymsg() Used for describing RPC reply messages. It trans‐
lates between the RPC reply message and its
external representation. This reply could be
either an acceptance, rejection or NULL.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
rpc(3C), xdr(3C), attributes(7)
Oracle Solaris 11.4 30 Dec 1996 rpc_xdr(3C)