svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_gss_set_svc_name(3c)
Standard C Library Functions rpc_gss_set_svc_name(3C)
NAME
rpc_gss_set_svc_name - send a principal name to a server
SYNOPSIS
#include <rpc/rpcsec_gss.h>
bool_t rpc_gss_set_svc_name(char *principal, char *mechanism,
u_int req_time,u_int program, u_int version);
DESCRIPTION
rpc_gss_set_svc_name() sets the name of a principal the server is to
represent. If a server is going to act as more than one principal, this
procedure can be invoked for every such principal.
PARAMETERS
Information on RPCSEC_GSS data types for parameters may be found on the
rpcsec_gss(3C) man page.
principal An ASCII string representing the server's principal name,
given in the form of service@host.
mech An ASCII string representing the security mechanism in
use. Valid strings may be found in the /etc/gss/mech file,
or by using rpc_gss_get_mechanisms().
req_time The time, in seconds, for which a credential should be
valid. Note that the req_time is a hint to the underlying
mechanism. The actual time that the credential will remain
valid is mechanism dependent. In the case of kerberos the
actual time will be GSS_C_INDEFINITE.
program The RPC program number for this service.
version The RPC version number for this service.
RETURN VALUES
rpc_gss_set_svc_name() returns TRUE if it is successful; otherwise, use
rpc_gss_get_error() to get the error associated with the failure.
FILES
/etc/gss/mech File containing valid security mechanisms
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library/security/rpcsec _ MT-Lev‐
elMT-Safe
SEE ALSO
rpc_gss_get_mechanisms(3C), rpc(3C), rpc_gss_get_principal_name(3C),
rpcsec_gss(3C), mech(5), attributes(7)
ONC+ RPC Developer's Guide
Linn, J. RFC 2078, Generic Security Service Application Program Inter‐
face, Version 2. Network Working Group. January 1997.
Oracle Solaris 11.4 22 Aug 2011 rpc_gss_set_svc_name(3C)