svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_gss_qop_to_num(3c)
Standard C Library Functions rpc_gss_mech_to_oid(3C)
NAME
rpc_gss_mech_to_oid, rpc_gss_qop_to_num - map mechanism, QOP strings to
non-string values
SYNOPSIS
#include <rpc/rpcsec_gss.h>
bool_t rpc_gss_mech_to_oid(charc*mech, rpc_gss_OIDc*oid);
bool_t rpc_gss_qop_to_num(char *qop, char *mech, u_int *num);
DESCRIPTION
Because in-kernel RPC routines use non-string values for mechanism and
Quality of Protection (QOP), these routines exist to map strings for
these attributes to their non-string counterparts. (The non-string val‐
ues for QOP and mechanism are also found in the /etc/gss/qop and
/etc/gss/mech files, respectively.) rpc_gss_mech_to_oid() takes a
string representing a mechanism, as well as a pointer to a rpc_gss_OID
object identifier structure. It then gives this structure values corre‐
sponding to the indicated mechanism, so that the application can now
use the OID directly with RPC routines. rpc_gss_qop_to_num() does much
the same thing, taking strings for QOP and mechanism and returning a
number.
PARAMETERS
Information on RPCSEC_GSS data types for parameters may be found on the
rpcsec_gss(3C) man page.
mech An ASCII string representing the security mechanism in use.
Valid strings may be found in the /etc/gss/mech file.
oid An object identifier of type rpc_gss_OID, whose elements are
usable by kernel-level RPC routines.
qop This is an ASCII string which sets the quality of protection
(QOP) for the session. Appropriate values for this string may
be found in the file /etc/gss/qop.
num The non-string value for the QOP.
RETURN VALUES
Both functions return TRUE if they are successful, FALSE otherwise.
FILES
/etc/gss/mech File containing valid security mechanisms
/etc/gss/qop File containing valid QOP values
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library/security/rpcsec _ MT-Lev‐
elMT-Safe
SEE ALSO
rpc(3C), rpc_gss_get_error(3C), rpc_gss_get_mechanisms(3C), rpc‐
sec_gss(3C), mech(5), qop(5), attributes(7)
ONC+ RPC Developer's Guide
Linn, J. RFC 2078, Generic Security Service Application Program Inter‐
face, Version 2. Network Working Group. January 1997.
Oracle Solaris 11.4 22 Aug 2011 rpc_gss_mech_to_oid(3C)