svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_gss_get_mechanisms(3c)
Standard C Library Functions
rpc_gss_get_mechanisms(3C)
NAME
rpc_gss_get_mechanisms, rpc_gss_get_mech_info, rpc_gss_get_versions,
rpc_gss_is_installed - get information on mechanisms and RPC version
SYNOPSIS
#include <rpc/rpcsec_gss.h>
char **rpc_gss_get_mechanisms();
char **rpc_gss_get_mech_info(char *mech, rpc_gss_service_t *service);
bool_t rpc_gss_get_versions(u_int *vers_hi, u_int *vers_lo);
bool_t rpc_gss_is installed(char *mech);
DESCRIPTION
These "convenience functions" return information on available security
mechanisms and versions of RPCSEC_GSS .
rpc_gss_get_mechanisms() Returns a list of supported security mecha‐
nisms as a null-terminated list of character
strings.
rpc_gss_get_mech_info() Takes two arguments: an ASCII string repre‐
senting a mechanism type, for example, ker‐
berosv5, and a pointer to a rpc_gss_service_t
enum. rpc_gss_get_mech_info() will return
NULL upon error or if no /etc/gss/qop file is
present. Otherwise, it returns a null-termi‐
nated list of character strings of supported
Quality of Protections (QOPs) for this mecha‐
nism. NULL or empty list implies only that
the default QOP is available and can be spec‐
ified to routines that need to take a QOP
string parameter as NULL or as an empty
string.
rpc_gss_get_versions() Returns the highest and lowest versions of
RPCSEC_GSS supported.
rpc_gss_is_installed() Takes an ASCII string representing a mecha‐
nism, and returns TRUE if the mechanism is
installed.
PARAMETERS
Information on RPCSEC_GSS data types for parameters may be found on the
rpcsec_gss(3C) man page.
mech An ASCII string representing the security mechanism in use.
Valid strings may also be found in the /etc/gss/mech file.
service A pointer to a rpc_gss_service_t enum, representing the cur‐
rent security service (privacy, integrity, or none).
vers_hi The highest and lowest versions of RPCSEC_GSS supported.
vers_lo
FILES
/etc/gss/mech File containing valid security mechanisms
/etc/gss/qop File containing valid QOP values
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library/security/rpcsec _ MT-Lev‐
elMT-Safe
SEE ALSO
rpc(3C), rpcsec_gss(3C), mech(5), qop(5), attributes(7)
ONC+ RPC Developer's Guide
Linn, J. RFC 2743, Generic Security Service Application Program Inter‐
face Version 2, Update 1. Network Working Group. January 2000.
NOTES
This function will change in a future release.
Oracle Solaris 11.4 14 May 2018
rpc_gss_get_mechanisms(3C)