svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rpc_gss_get_error(3c)
Standard C Library Functions rpc_gss_get_error(3C)
NAME
rpc_gss_get_error - get error codes on failure
SYNOPSIS
#include <rpc/rpcsec_gss.h>
bool_t rpc_gss_get_error(rpc_gss_error_t*error);
DESCRIPTION
rpc_gss_get_error() fetches an error code when an RPCSEC_GSS routine
fails.
rpc_gss_get_error() uses a rpc_gss_error_t structure of the following
form:
typedef struct {
int rpc_gss_error; RPCSEC_GSS error
int system_error; system error
} rpc_gss_error_t;
Currently the only error codes defined for this function are
#define RPC_GSS_ER_SUCCESS 0 /* no error */
#define RPC_GSS_ER_SYSTEMERROR 1 /* system error */
PARAMETERS
Information on RPCSEC_GSS data types for parameters may be found on the
rpcsec_gss(3C) man page.
error A rpc_gss_error_t structure. If the rpc_gss_error field is
equal to RPC_GSS_ER_SYSTEMERROR, the system_error field will
be set to the value of errno.
RETURN VALUES
Unless there is a failure indication from an invoked RPCSEC_GSS func‐
tion, rpc_gss_get_error() does not set error to a meaningful value.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library/security/rpcsec _ MT-Lev‐
elMT-Safe
SEE ALSO
perror(3C), rpc(3C), rpcsec_gss(3C), attributes(7)
ONC+ RPC Developer's Guide
Linn, J. RFC 2078, Generic Security Service Application Program Inter‐
face, Version 2. Network Working Group. January 1997.
NOTES
Only system errors are currently returned.
Oracle Solaris 11.4 22 Aug 2011 rpc_gss_get_error(3C)