svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
rewinddir(3c)
Standard C Library Functions rewinddir(3C)
NAME
rewinddir - reset position of directory stream to the beginning of a
directory
SYNOPSIS
#include <sys/types.h>
#include <dirent.h>
void rewinddir(DIR *dirp);
DESCRIPTION
The rewinddir() function resets the position of the directory stream to
which dirp refers to the beginning of the directory. It also causes the
directory stream to refer to the current state of the corresponding
directory, as a call to opendir(3C) would have done. If dirp does not
refer to a directory stream, the effect is undefined.
After a call to the fork(2) function, either the parent or child (but
not both) may continue processing the directory stream using read‐
dir(3C), rewinddir() or seekdir(3C). If both the parent and child pro‐
cesses use these functions, the result is undefined.
RETURN VALUES
The rewinddir() function does not return a value.
ERRORS
No errors are defined.
USAGE
The rewinddir() function should be used in conjunction with opendir(),
readdir(), and closedir(3C) to examine the contents of the directory.
This method is recommended for portability.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
seekdir(3C), fork(2), closedir(3C), dirfd(3C), opendir(3C), read‐
dir(3C), telldir(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014 rewinddir(3C)